Submit Your Article Forum Rules

Results 1 to 9 of 9

Thread: CactuShop

Hybrid View

  1. #1
    Senior Member
    Join Date
    Dec 2003
    Posts
    349

    CactuShop

    hi guys...


    I've got a new client and they're using CactuShop shopping cart (trolley)... first thing I want to do is change the <title> on their home page, but for the life of me I can't find where to change this. I can change the titles on the product page no problem, but the index page... nope.

    I could hack the _default.asp page but that would give the same page title throughout the site, which i don't want.

    Has anybody any experience with CactuShop (v6)? If so, any ideas on changing the page title on the index page?

  2. #2
    Junior Member
    Join Date
    Feb 2012
    Posts
    4
    Hi,

    Nice and simple when you know how. Firstly _default.asp is the backend system so any changes to that will not give you the change of title tag you are looking for, and it will not set anything throguhout the site so I'd leave that page alone for now.

    To set the title tag you need to set the following variable before the buildpage.asp include.

    So above <!--#include file="includes/buildpage.asp"--> on default.asp you need to put something like this <%strPageTitleHTML = "Your title tag here"%>

    Hope that helps

    Kev

  3. #3
    Junior Member
    Join Date
    May 2012
    Posts
    1
    Hi Kev,

    I noticed a couple of your posts around the web regarding cactushop. I Would be interested in discussing the possibility of having some work (sitemap and SEO) carried out on our Cactushop based store.

    Look forward to hearing from you.

    Regards
    Andrew

  4. #4
    Senior Member
    Join Date
    Dec 2003
    Posts
    349
    Thank you Kev... that worked a treat!

    i tried to follow your lead and define the meta description and keywords in the same way:

    <%strMetaDescriptionHTML = "my description"%>
    <%strMetaKeywordsHTML = "my keywords"%>

    it works for the keywords but not the description... i know bugger all about ASP, so any advice would be appreciated... i might even click that 'reputation' button.
    Last edited by hawkwind dave; 02-08-2012 at 10:35 AM.

  5. #5
    Junior Member
    Join Date
    Feb 2012
    Posts
    4
    Hi Dave,

    More than happy to help I work with Cactushop day in day out so sad as it seems there is little I've not come accross in modifying it to work how you want it to, particularly from an SEO point of view.

    I think it's as simple as the fact you are using the wrong variable for the description try <%strMetaDescHTML = "your description" %>

    Hope that helps

    Kev

  6. #6
    Junior Member
    Join Date
    Feb 2012
    Posts
    2
    @KevBallard:
    I keep getting this error, maybe you have seen it before?
    "An ASP error occurred when trying to send the data via XML object : The server returned an invalid or unrecognized response".

    It seems to be related to some invalid information being sent by the server. Apart from that I have no idea what I did to break it

  7. #7
    Junior Member
    Join Date
    Feb 2012
    Posts
    4
    Hi,

    You might need to be a bit more specific about what it is you are trying to do when you get this error. The only time I've seen this is when trying to process orders through PayPal or Google Checkout. Both of these payment methods use a behind the scenes call back to the website to confirm if an order has been successful or not. I think the fix was to change the XML object type because the one that was being used by Cactushop was not supported by the server it was hosted on.

    I assume you are not looking at the checkout area of the site though as you'd not see this error on the screen, it would only be in the payment gateway control panel debugging area. So if you'd like to expand on what you are trying to do it might help.

    Either way I think you need to look for where the object is being created, it'll look something like this Set objXmlHttp = Server.CreateObject("MSXML2.ServerXMLHTTP") and change the part inside the brackets to whatever suits your server. One alternative appears to be Server.CreateObject ("Microsoft.XMLHTTP") but I'm sure there are others. This is all assuming you are trying to read in an XML document from somewhere and that’s what’s causing the error.

    Any help? probably not but I had a go

    Kev

  8. #8
    Senior Member
    Join Date
    Dec 2003
    Posts
    349
    Is there a way i can put an <a href> or [link=] in the 'front page news' items? I need to put some clicky images in but cant seem to make the images clicky.

  9. #9
    Junior Member
    Join Date
    Feb 2012
    Posts
    4
    Hi Dave,

    Not sure what the problem is your having. From what you say you are editing the front page using the Front News Items feature, but when you try to put a 'a href=' around the image tag it strips it out, is that right? Or have you just not tried manually typing the link in?

    I have seen a similar issue in a different area of the site but not with these news item. Looking at the site you PMed me everything seems to link to the right places am I missing something?

    Would have replied to your PM but apparently I can not message members till I have posted over 10 messages on the forum.

    Kev

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •